ago in Mazda by
After browsing the internet for a while to find an answer to my problem (or rather my problems). But did not find anything. If there are already posted solutions, I apologize in advance.

I have been the owner of a Mazda3 built in 2020 for almost 3 months now. I really love my baby and I love driving it so much! But it also has some hiccups.

And what's most annoying are the problems with Android Auto, which I've only been using for 3 months.

My phone is a OnePlus 7 Pro, of course Android Auto is installed on it. And in itself, connectivity is completely unproblematic. I do not know the failures etc., of which a lot is reported.

The problems I have are as follows. (I number them so that the answer may be easier)

1. Control of Google Maps
In the beginning it worked perfectly. For 2-3 weeks now I have had the problem that I can use Google Maps normally after starting Android Auto. I can enter the destination (mostly) and then start the navigation.

But then Google Maps can no longer be controlled. I also have to say that the Mazda3 system does not have a touch display, but is controlled by a rotary push-button (I think it was called that).

So I can jump from field to field by pressing left or right and select by pressing.

This is no longer possible for maps. I can no longer select the card. By pressing left or right, the "cursor" jumps from the far right (for me mostly the track just played in Spotify) directly to the far left to the bar to switch from there to the Spotfy apps or voice input.

However, I can neither press nor turn the middle window of Maps, for example to change the destination, the view etc. or to show me an alternative route.

Navigation continues without problems, I just can't get into the map.

2. Destination entry and navigation are deleted after the start.
Since it is difficult to simply look at the route beforehand in Android Auto and also consider alternatives, I often choose the route in advance on my mobile phone before I connect it, since access to maps on my mobile phone is denied as soon as it reaches the car connected. I have already discovered that when you start the navigation on the mobile phone, it is displayed on the Mazda screen immediately after connection, so that I do not have to do anything else.

Unfortunately, Android Auto loses the route again after a few seconds and shows maps without route guidance.

I have to unplug the cell phone several times and plug it in again (as in old Windows times "switch it of and on again") until it also maintains the navigation.

Sometimes Android Auto gets out of it completely. I presumably overwhelm it.

3. Mazda or phone problem?
Is it a Mazda problem, should I raise it at the dealership? Or is it an Android / OnePlus problem for which Mazda can't do anything?

These are the two biggest problems that of course distract me and absolutely annoy me even while driving.

Does anyone have similar problems or need advice? I would be very happy to receive advice and thank you very much in advance for your help.:)

8 Answers

+1 vote
ago by
 
Best answer
If the music on Spotify falters, please check the following settings, at least that helped me: if you are connected to Android Auto and play the music via Spotify, go to the Bluetooth settings on your mobile phone. There you open the settings for the currently connected device (i.e. your Mazda radio). Now you should be able to select and deselect different things, here it is important that the check mark at "Media Audio" or "HD Audio" is deactivated. The problem with the whole thing is that the cell phone is connected to Bluetooth and cable, and then some cell phones do not seem to know exactly how to transmit the music. Connect again to end all apps and, if necessary, disconnect the cable once and switch the ignition off and on again.

The Bluetooth setting is usually saved, but after updates or so it can sometimes happen that you have to deactivate the option again. Since then, Spotify has been running in the finest quality without any dropouts ;-)
+1 vote
ago by
Hello, it would be quite possible that it is your phone and not the car. Can you look in Infotainment system what version you have, should be under Settings / System information! If you have version 10047 you are up to date, if not there would be an update available.
+1 vote
ago by
I also had these and similar problems with my OnePlus 6T and have never found a solution. What I can now imagine is that the Android Auto does not work correctly and deleting and reinstalling it may solve the problem, furthermore the energy saving option in Android for Android Auto could also be a problem.

Unfortunately, I can no longer test any of the options because I switched to a Pixel 4 and everything works very well there.

Hope that helps.
+1 vote
ago by
I'm not quite sure if I understood it correctly. Do you get into the google maps app when you press the navigation button next to the rotary push button (you have to be in the Android Auto app beforehand)? And can you then select various buttons in the Android Auto App by turning the rotary push button? Because as I understand it, you just push the switch left or right, then it jumps from one app to the next, but I'm not sure if you meant that.
ago by
Basically, I don't have to use the navigation button to get to Google Maps. Therefore I cannot answer this question specifically. But can test it tomorrow morning on the way to work if it is relevant.

The normal procedure is (if I have GPS on) I connect the phone via USB (with OnePlus Type C) and Android Auto is activated on the phone immediately. If I then select Android Auto via infotainment, which he then immediately offers me next to the Mazda start interface, it switches to Android Auto and I have the Android Auto view with maps in the middle, clock and Spotify on the right and the menu items for app overview on the left.

With the rotary push button, I can actually switch to any item that can be selected, including the content in maps such as destination entry, alternative route, change view, zoom, etc.

But especially during navigation, I can no longer control Google Maps with the rotary push button.

I hope I was able to explain the problem better this time.
+1 vote
ago by
Have you tried another navigation app?

You don't have to demonize the cell phone right away ...

I've been using WAZE for years and I'm super happy with it.
+1 vote
ago by
Just tested. One Plus 7 Pro works perfectly, all points can be reached and selected with the rotary control. Android Auto version 5.3.501644-release

Check for an update or try another USB cable.
+1 vote
ago by
I'm having the same issue, when AA first starts Google maps works fine. After a few mins I'm unable to do anything with the map. I can still cycle through the AA icons on the bottom but cannot interact with the map.
+1 vote
ago by
I have all these issues and worse, Waze refuses to launch if it AA has a seizure and I have to put cycle the car. I have a oneplus 5t and the 2019 3. And yeah I have changed the cable, Android auto is up to date, on my phone I just don't know what the solution is. Took it to the dealership but no solution
ago by
Honestly I think it's a OnePlus problem. I just got an 8Pro and have noticed that after a few minutes I can't interact with the upper portion of the screen in AA anymore. It works fine if I start navigation immediately. I had a Pixel before and never had this issue, which makes me believe it is a OnePlus issue.

Related questions

1 answer
asked 1 year ago in Mazda by Heidi
4 answers
asked 2 years ago in Mazda by Nic Glover
1 answer
asked 2 years ago in Mazda by Bertie Collins
1 answer
2 answers
1 answer
Commenting Policy | Privacy Policy | Contact Us
WheelsJoint Logo
©2022 WheelsJoint. All rights reserved.
...